Closed - Major Incident #2423818268

Issue affecting central Manchester sites.

Closed 2 years ago
Incident affecting: Manchester
 
The issue has been identified as a fault with a fibre. Engineers are currently on site and trying to find the exact location of the break.
 

Updates(most recent first)

  • We are now happy that this issue has been solved. Thank you for your patience.

    The issue was a break in a backhaul fibre cable, once this break was repaired connectivity was restored.

    Incident state changed to 'Solved'
    2 years ago - 8:33am on 17th January 2022
  • This incident has been logged and our team is now working to diagnose and fix the problem.

    Incident created
    2 years ago - 2:20pm on 14th January 2022

Need help?

That's what we are here for - get in touch!

© Telcom Networks Limited | VAT number GB 190 631 121 | NorthStar, 135-141, Oldham Street, Manchester, M4 1LN | CN 09085579, registered in England & Wales