Closed - Major Incident #6608641722

Central Manchester outage

Closed 16 days ago
Incident affecting: Central Manchester Area
 
Good Morning,

We aware of alerts for some circuits in Central Manchester being offline from around 9am.
We are investigating currently and will update as soon as we have further information to share.
 

Updates(most recent first)

  • We are now happy that this issue has been solved. Thank you for your patience.

    Incident state changed to 'Solved'
    16 days ago - 6:02am on 29th April 2024
  • Good Morning,

    We can see Servcies impacted by the power works have resumed as of 11:40 today.
    We will monitor for a period as follow-up.

    17 days ago - 12:18pm on 28th April 2024
  • Good Morning,

    We can see Servcies impacted by the power works have resumed as of 11:40 today.
    We will monitor for a period as follow-up.

    17 days ago - 11:58am on 28th April 2024
  • Update:
    Further checks at the site are showing a Power Outage in the area which has caused this service outage.
    We anticipate all services resuming following power being restored at our Site and are monitoring actively whilst the Incident is live.
    We will update upon Service restoration.

    17 days ago - 10:04am on 28th April 2024
  • This incident has been logged and our team is now working to diagnose and fix the problem.

    Incident created
    17 days ago - 9:50am on 28th April 2024

Need help?

That's what we are here for - get in touch!

© Telcom Networks Limited | VAT number GB 190 631 121 | NorthStar, 135-141, Oldham Street, Manchester, M4 1LN | CN 09085579, registered in England & Wales